当 pidgin 遇到 core-plugin_pack-buddynote

升级 Gutsy 之后,开始整理自己之前编译过的软件。这部分大都是因为源里太过陈旧而忍不住自己编译的,比如 emacs,pidgin 等等。升级之后,源里的版本非常新,于是准备把原来这些自行编译的都去掉。

问题发生在 pidgin 上。当把自己编译的 pidgin 给 make uninstall 了之后,登录 pidgin 突然出现这样的错误(大意):
core-plugin_pack-buddynote 未找到,请安装该 plugin 之后再试一次。


这毛病有点令人丈二和尚摸不着头脑,将源里的 pidgin 重新安装,故障依旧。难道是我的 .purple 有问题?把 .purple 挪到别的地方,重启 pidgin,添加帐户的时候居然协议下拉列表里什么都没有。

没辙了。正准备 sudo apt-get autoremove --purge pidgin*,突然发现 pidgin 相关的包里面还有一个 pigdin-extprefs,看了看说明,很可疑啊,先安装之,把 .purple 挪回来,顺手 grep 了一下,将 pref.xml 里面带 /usr/local 的标签都干掉,启动 pidgin,一切正常。

按说这么重要的包,不应该装 pidgin 的时候不自动安装上啊!
发表评论